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Topic:

In this tutorial we will use data acquired by the ALOS PALSAR sensor operated by

the Japan Aerospace Exploration Agency (JAXA) in the years 2007 and 2010 in order

to see man-made changes to a forested area.

ALOS PALSAR data are acquired in L-band at a wavelength of 27 cm. This is a

much longer wavelength compared to Sentinel-1 C-band data acquired at 5.5 cm.

Therefore ALOS PALSAR
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Input Data:

• 4 files = 2 ALOS PALSAR HH-HV pairs acquired at L-band from 2007 and one
pair from 2010

• 2007:

• S06W056_07_sl_HH_db.tif

• S06W056_07_sl_HV_db.tif

• 2010

• S06W056_10_sl_HH_db.tif

• S06W056_10_sl_HV_db.tif

• SAR data part of the freely available data set “Global PALSAR-2/PALSAR/JERS-1
Mosaics and Forest/Non-Forest Maps”

• Spatial resolution: 0.8 arc seconds (approx. 25 m at the Equator)
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ALOS

- ALOS stands for Advanced Land Observing Satellite

- Operated by JAXA (Japan Aerospace Exploration Agency)

ALOS 1

- launch: 24.01.2006 

- end of mission: 12.05.2011 (after a malfuntion on 22.04.2011)

- SAR-Sensor PalSAR, operated at L-band (wavelength f 23.62 cm)

- https://www.eorc.jaxa.jp/ALOS/en/alos/a1_about_e.htm

https://www.eorc.jaxa.jp/ALOS/en/alos/a1_about_e.htm
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Global PALSAR-2/PALSAR/JERS-1 Mosaics and Forest/Non-Forest Maps are available at:

https://www.eorc.jaxa.jp/ALOS/en/dataset/fnf_e.htm

(free registration required)

https://www.eorc.jaxa.jp/ALOS/en/dataset/fnf_e.htm
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Drag & Drop

Step 1: Open input data

Load data
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Locate the data

Click at tab “Word View”

Click the left mouse 
button, hold it and move 
the mouse to turn the 
globe! 

Use the mouse wheel to 
zoom in and out!
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View image bands

Single left mouse 
click opens the 
node.
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View image bands

Double left mouse 
click opens the 
band in the image 
viewer.
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View image bands

Double left mouse 
click opens the band 
in the image viewer.
Do this for the HH 
data from 2007 and 
2010!

From the menu, select 
“Window” -> “Tile 
Horizontally”!
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View image 
bands

Now both image bands 
are display next to 
each other.
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View image 
bands

Select the “Hand” icon from the toolbar. 
Click into the image, hold down the left 
mouse button and move the mouse back 
and forth to move the image content! 
Use the mouse wheel to zoom in and out!
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Create Layer Stack

From the menu, select 
“Raster” -> “Geometric” -> 

“Collocation”!
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Create Layer Stack

In the drop down menu, select 
the HV data from 2007!
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Create Layer Stack

As slave product, the HH 
data from 2007!
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Create Layer Stack

Specify the output name as 
“S06W056_07_sl_HV_HH_db”!

Specify the output directory!

Specify the master 
components name as 

“${ORIGINAL_NAME}_HV”!

Specify the master 
components name as 

“${ORIGINAL_NAME}_HV”!
Click “Run”!

Result: Layer 
Stack with 
two layers:
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Calculate Polarization Ratio

2) Specify the 
output name as 

“ratio”!

1) From the menu, select 
“Raster” -> “Band Maths…”! 3 Click at “Edit 

Expressions…”!
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Attention! Remember the 
calculation rules for logarithmic 
values!

Calculate Polarization Ratio

Enter the formula to calculate the 
polarization ratio of HH and VV!

Please remember: Pixel values are 
given in dB, which means they are 
in the logarithmic domain!

Therefore you have to subtract HV 
from HH!

Click “OK”!



Forest Monitoring 19

Calculate Polarization Ratio

Click “OK”!

The result of the calculation 
will be added as a new 

virtual band. To convert it to 
a permanent band, select 
the band “ratio”, click the 

right mouse button and 
select “Convert Band” from 

the context menu!
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Calculate Polarization Ratio

The result of the calculation 
will be added as a new 

virtual band. To convert it to 
a permanent band, select 
the band “ratio”, click the 

right mouse button and 
select “Convert Band” from 

the context menu!

Alternative:
Untick this option in the Band 
Maths window before starting the 
calculation!
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Create RGB-View

In the Product Explorer, select 
the Layer Stack product name 

and click the right mouse 
button!

From the context menu select 
“Open RGB Image Window”!
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Create RGB-View

To select image bands for 
the three RGB-Image-

Channels, use the drop 
down menus and select a 

band from the list!
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Create RGB-View

To select image bands for 
the three RGB-Image-

Channels, use the drop 
down menus and select a 

band from the list!
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Create RGB-View

For our exercise, select
Red: HH band

Green: HV band
Blue: ratio  

Click “OK”!
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Select the “Hand” icon from the toolbar. 
Click into the image, hold down the left 
mouse button and move the mouse back 
and forth to move the image content! 
Use the mouse wheel to zoom in and out!

Create 
RGB-View
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Speckle-Filtering

From the menu select “Radar” -> “Speckle Filtering” -> “Single Product Speckle Filter”!
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2) SNAP 
automatically adds 
“_Spk” at the end of 
the file name to 
create the output 
name

1) The Layer Stack is our 
source product.

Speckle-Filtering

3) Specify your 
output directory!

4) Click the tab “Processing Parameters”!
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1) Select the source 
bands!

2) As filter select 
“Lee” from the drop 

down menu!

3) Enter 5 as X and 
Y filter size!

Click “Run”!
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Create 
RGB-Views

Use the speckle 
filtered product to 

create an RGB-
View!

See slides 21 – 25. 
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Compare 
RGB-Views

Compare the unfiltered 
and the filtered RGB-

Views using horizontal 
tiling!

See slides 10 - 12!
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View pixel values

From the menu select “View” -> 
“Tool Windows” -> “Pixel Info”!
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View pixel values

Please open speckle 
filtered HV data by double-
clicking the image band!
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When you have selected 
the hand tool and you 
move the mouse pointer 
over the image, you can 
see the pixel information 
in the Pixel View tool 
window, e.g. the value of 
the band_1_HV amplitude.

View pixel values

Observe the pixel values of the forested areas (white to light grey areas) and the non-forested areas 
(dark regions)!
You will notice that the backscatter values for the forested areas will range between -10 and -12 dB, 
whereas the non-forested areas show much lower backscatter values in the range from -19 to -22 dB.
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Mask area covered by forest

3) Specify the 
output name as 

“ratio”!

2) Open the “Band Maths…“ tool

1) Select the speckle-
filtered Layer Stack!

5) Click “Edit Expressions…”

4) Untick this option!
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Mask area covered by forest

Enter the expression: 
if $6.band_1_HV < -15 then 0 else 1

This means: If the pixel value of band_1_HV is lower then 15, save a “0” at 
this pixel position. If it is larger, then save a “1” at the pixel position.

Click “OK” to close the window!
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Mask area covered by forest

Click “OK” to start the calculation!
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Mask area 
covered by 
forest

Result:

Black pixels -> Pixel value = 0 -> 
non-forested area

White pixels -> Pixel value = 1 -> 
forest area
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Repeat these steps for the data 
set from the year 2010!
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The forest-non-forest mask for he 
data from the year 2010 also 
contain:

Black pixels -> Pixel value = 0 -> 
non-forested area

White pixels -> Pixel value = 1 -> 
forest area
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Compare the masks 
from 2007 and 2010 

using horizontal tiling!

See slides 10 - 12!

Compare 
masks

2007 2010

Trying to find places where 
there was forest in 2007 but 
not in 2010.
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Create Layer Stack
To combine both speckle-filtered products with the forest-non-forest mask in one layer stack, we 
use the Collocation tool again.

From the menu, select 
“Raster” -> “Geometric” -> 

“Collocation”!
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Create Layer Stack
1) As Source Product (Master), select 

speckle-filtered product containing 
data and mask for the year 2007!

2) As Slave Product, select speckle-
filtered product containing data and 

mask for the year 2010!

5) Specify the master components 
name as “${ORIGINAL_NAME}_2007”!

6) Specify the master components 
name as “${ORIGINAL_NAME}_2010”!

3) Specify the output name, e.g. 
“collocate”!

4) Specify the output directory!

Click “Run”!
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In SNAP 9 an error occurs at this stage of processing! 

This was not the case for the last years version of SNAP, version 8. Most probably this will 
be fixed with on version-9 internal update.

For the moment, we will show you a work-around in the next slides.
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Create Layer Stack – Work Around

1) Select the speckle-
filtered product with 

data and mask for the 
year 2010 in the 

Product Explorer! 2) Open the “Band Maths…“ tool
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Create Layer Stack – Work Around

1) Target Product is 2010 data set

2) Enter new band name, e.g. 
“forest_mask_2007”!

3) Untick this option!

4) Click at “Edit Expression!”
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Create Layer Stack – Work Around

1) From the drop down menu, select 
the 2007 data set!
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Create Layer Stack – Work Around

1) With a single mouse click at the 
entry $x.forest_mask_2007, this 

band is transferred to the Epression
entry window.

Click “OK” to close the window!
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Click “OK” to finally 
transfer the band!

Create Layer Stack – Work Around
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Create Layer Stack – Work Around

As a result, we now have both 
forest masks in one product.
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Create Forest Change Product

2) Open the “Band Maths…“ tool

1) Select the 2010 product 
containing both forest masks 
(from the year 2007 and 2010)!
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Create Forest Change Product

1) Enter name of new band, 
e.g. “forest_change”!

2) Untick this option!

3) Click at “Edit Expression…”
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Create Forest Change Product

To calculate the forest change, 
subtract the 2010 forest-non-
forest mask from the 2007 forest-
non-forest mask!

Click “OK” to 
close the window!
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Create Forest Change Product

Click “OK” to finally calculate the 
forest change product!
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Create Forest 
Change Product

As a result, we only 
get the areas where 
there was a change 
between 2007 and 
2010.
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Forest Mask 2007 Forest Mask 2010 Difference 2007 - 2010

In 2010 these features (most probably clear-cuts) appeared 
or increased in size when compared to the 2007 data. In the 
difference map, only those feature remain, which 
experienced a change between the two years.
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